Citrix Receiver... I don't even no where to start with all the issues I had/have and workarounds I have in place to make Receiver at least somewhat useable. The whole thing with Receiver/StoreFront is so "touchie"...anyway, now I just want to let you know something about proxies with Receiver.

Upfront: Most companies I work with are using proxy servers for any web connection. I was in a customer transition and we simply took over the existing proxy policy settings. 

When the whole Receiver "gang" starts - AuthService, Self-Service, Receiver.... it doesn't just take a long time (try it on old Windows embedded XP Thin Clients) it also tries to connect to the StoreFront URL. 

The "gang" starts but then nothing? Ok, I have to do what I always do, troubleshoot the issue. I enabled logging and find that the AuthService runs into an exception when reading the proxy settings. Then I took a closer look at the proxy exceptions and find something like 10.0.0.0/24. Now this is NOT correct for Internet Explorer (btw. Internet Explorer didn't care about those entries) and I changed it to 10.0.0.* 

Next trace the AuthService is using the same proxy exceptions? Even I changed it and verified the usual proxy registry key. After a lot more troubleshooting, I found that the AuthService is using the following binary keys 

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections
DefaultConnectionSettings
SavedLegacySettings

Once I deleted those keys the right proxy exception where used and apps finally showed up!

I made an enhancement request to Citrix to build something in group policy or wherever to be able to disable the use of any proxy for the Receiver gang.

 


Add comment