Can not connect to the citrix xenapp server

  • Posts: 3
  • Thank you received: 0

AusSupport created the topic: Can not connect to the citrix xenapp server

HI,

I've got (XenApp Fundermental 6) WI 5.3 and CG 3.2 configured on a Windows 208 R2 Box. XML port 8001. Secure Gateway diagnostic no errors . Secure access in WI is configured with beow

Web Sites
External: server1.mydomain.com:8080/citrixaccess - gateway direct
Internal:http://server1.mydomain.com/citrixaccess - direct

Services Sites

External: server1.mydomain.com:8080/citrixaccess - direct
Internal:http://server1.mydomain.com/citrixaccess - direct

Internally this farm works like a charm. Externally apps will not load - and I will get prompted with "No XenApp Server Exists and can not accepting etc etc". In the CSG event logs I'm receiving many SSL handshake failures. looking at the client launch.ica in notepad the address is pointing to a my server on port 1493 - not the external ip.

When i change this APP ip to external app launch


Also - on the firewall I've enabled Public to Private NAT All ports are enabled and can telnet.

citrix.mycompany.com ---> 203.147.146.115
> 192.168.1.25

I even try ALTADDR /set publicipaddress


Any idea?

Thanks,
As
#46

Please Log in or Create an account to join the conversation.

  • Posts: 137
  • Karma: 2
  • Thank you received: 5

koetzing replied the topic: Can not connect to the citrix xenapp server

With CSG YOU MUST use 443/SSL from external.

Service and Web
External:
httpS://server1.mydomain.com/citrixaccess
<- gateway direct

The STA Server must point to
http://server:8001/scripts/ctxsta.dll

ALTADDR is NOT required and should NOT be used with CSG

CSG is a reverse proxy that can and will forward http traffic to IIS

cheers,
Thomas
#48

Please Log in or Create an account to join the conversation.